[Interchange-bugs] [Bug 184] New - Error setting cart inside a loop

[email protected] [email protected]
Thu, 10 May 2001 18:29:40 -0400


http://developer.akopia.com/bugs/show_bug.cgi?id=184

*** shadow/184	Thu May 10 18:29:40 2001
--- shadow/184.tmp.26467	Thu May 10 18:29:40 2001
***************
*** 0 ****
--- 1,47 ----
+ Bug#: 184
+ Product: Interchange
+ Version: 4.6.3
+ Platform: Other
+ OS/Version: All
+ Status: NEW   
+ Resolution: 
+ Severity: major
+ Priority: P2
+ Component: Core
+ AssignedTo: [email protected]                            
+ ReportedBy: [email protected]               
+ URL: N/A
+ Cc: 
+ Summary: Error setting cart inside a loop
+ 
+ I want to set a loop that will select some cart to show. I cannot hardcode the
+ carts Ids for many reasons.
+ 
+ If I try something like:
+ 
+ ===================
+ [loop interpolate=1 arg="cart1 cart2"]
+    [cart interpolate=1 name="[loop-code]"]
+    [item-list]
+ .....
+    [/item-list]
+ [/loop]
+ 
+ ==================
+ 
+ The system tries to read from cart "[loop-code]" twice and not from "cart1" and
+ "cart2".
+ 
+ I tried also with
+ 
+ -- [seti var][loop-code][/seti][cart interpolate=1 name="[scratch var]"]
+ -- [seti var][loop-code][/seti][perl]$Tag->cart( $Scratch->{var} )[/perl]
+ 
+ with _exactly_ the same results. It seems that [loop-code] is not interpolated
+ when passed to the functions. It is printed correctly, though, if I print
+ [scratch var], I get "cart1" and "cart2".
+ 
+ Do you have any suggestion on how to get what I need?
+ 
+ thanks
+      )\(elson