[ic] magic number checking on storable file failed

Doug Alcorn [email protected]
29 Nov 2000 03:09:40 -0500

I saw in the mailing list "archive" (searching akopia.com with google)
discussion about this issue: DkzkexsV: - [29/November/2000:03:02:11
-0500] construct /cgi-bin/construct/admin/index.html Runtime error:
Magic number checking on storable file failed at blib/lib/Storable.pm
(autosplit into blib/lib/auto/Storable/_retrieve.al) line 275, at
/usr/local/interchange/lib/Vend/SessionFile.pm line 87

The solution given by Mike was that the gdbm and session files were
"old".  It's true I tried to restore a catalog's directory from a
backup after I had updated all the various perl modules via CPAN.
However, on a whim I created a virgin construct catalog and still got
the same error.

What happens is that I can load up the "entry" page just fine.  When I
enter as a customer not all of the index.html page loads.  It acts
like it's getting cut off in the middle.  Anyway, a page loads.  For
construct, it is just a blank white page.  On my other catalog I
actually got a form loaded that would allow me to go to another page.
If I either submit the form or go back to the entry page and try and
enter the admin area I get the above error.

Since I'm using MySQL 3.23 I don't have any gdbm files on the virgin
construct.  Also, when I start this whole thing off my session
directory is empty.  I need some help.
 (__)  Doug Alcorn (mailto:[email protected] http://www.lathi.net)
 oo /  Unix Hacker
 |_/   "It's too late for paradise" (at least in this life)