[ic] search in chinese

David Christensen david at endpoint.com
Thu Jan 29 23:00:12 UTC 2009


Darnell,

> I have a client that has English language and Chinese language. but  
> the
> search only searches in English. but Chinese I get Sorry, there was an
> error in processing this form action. Please report the error or try
> again later. (Wide character in subroutine entry at
> /usr/local/interchange/lib/Vend/Util.pm line 599. ). What do I need to
> do to fix this.


We have committed a fix for this in CVS.  You can also apply this  
patch directly to your interchange directory:

http://www.icdevgroup.org/cgi-bin/cvsweb/interchange/lib/Vend/Util.pm.diff?r1=text&tr1=2.121&r2=text&tr2=2.122

Regards,

David
--
David Christensen
End Point Corporation
david at endpoint.com
212-929-6923
http://www.endpoint.com/
----
--- interchange/lib/Vend/Util.pm	2009/01/08 18:43:13	2.121
+++ interchange/lib/Vend/Util.pm	2009/01/29 22:52:38	2.122
@@ -1,6 +1,6 @@
  # Vend::Util - Interchange utility functions
  #
-# $Id: Util.pm,v 2.121 2009/01/08 18:43:13 docelic Exp $
+# $Id: Util.pm,v 2.122 2009/01/29 22:52:38 danb Exp $
  #
  # Copyright (C) 2002-2008 Interchange Development Group
  # Copyright (C) 1996-2002 Red Hat, Inc.
@@ -26,6 +26,8 @@
  package Vend::Util;
  require Exporter;

+use Encode qw(encode_utf8);
+
  @ISA = qw(Exporter);

  @EXPORT = qw(
@@ -91,7 +93,7 @@ use Safe;
  use Vend::File;
  use subs qw(logError logGlobal);
  use vars qw($VERSION @EXPORT @EXPORT_OK);
-$VERSION = substr(q$Revision: 2.121 $, 10);
+$VERSION = substr(q$Revision: 2.122 $, 10);

  my $Eval_routine;
  my $Eval_routine_file;
@@ -596,7 +598,7 @@ if(! [email protected]) {
  	$Keysub = sub {
  					@_ = time() unless @_;
  					$Md->reset();
-					$Md->add(@_);
+					$Md->add(map encode_utf8($_), @_);
  					$Md->hexdigest();
  				};
  }




More information about the interchange-users mailing list