[ic] Upgrade to Interchange-5.7.4 performance issues

Bill Carr bill at bottlenose-wine.com
Tue Mar 23 14:07:31 UTC 2010

On Mar 22, 2010, at 4:11 PM, Peter wrote:

> On 23/03/10 03:51, Bill Carr wrote:
>> I just tried again with vlink and I still get the performance
>> problems. I posted a new strace here
>> http://www.bottlenose-wine.com/userfiles/strace.txt. Anymore ideas? I
>> sure don't want to be orphaned off in 5.4.0 land forever.
>> From the looks of it, you're using your system perl which is 5.10.1.  If
> this is a threaded perl it could explain some of the slowdown.  Can you
> try compiling your own perl 5.8.9 and see how it works out?  There's
> some directions at:
> http://cloud.github.com/downloads/pajamian/stuff/Rackspace_Interchange_Setup.html
> Scroll down to "Section 10: Compiling Your own Perl".
I don't think this perl is threaded:

www at pimmscup:~$ perl -V
Summary of my perl5 (revision 5 version 10 subversion 1) configuration:
    osname=linux, osvers=2.6.32-trunk-amd64, archname=x86_64-linux
    uname='linux pimmscup 2.6.32-trunk-amd64 #1 smp sun jan 10 22:40:40 utc 2010 x86_64 gnulinux '
    config_args='-des -Dprefix=/usr'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=undef, usemultiplicity=undef
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
    cc='cc', ccflags ='-fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    cppflags='-fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='4.3.4', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -fstack-protector -L/usr/local/lib'
    libpth=/usr/local/lib /lib /usr/lib /lib64 /usr/lib64
    libs=-lnsl -ldb -ldl -lm -lcrypt -lutil -lc
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc
    libc=/lib/libc-2.10.2.so, so=so, useshrplib=false, libperl=libperl.a
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector'

Characteristics of this binary (from libperl): 
                        USE_64_BIT_INT USE_LARGE_FILES USE_PERLIO
  Built under linux
  Compiled at Feb 11 2010 10:52:46

Could 5.8.9 make a difference or do you just want to make sure my perl is not threaded? I think I'm using some features that are only available in > 5.10.

Bill Carr 
Bottlenose - Wine & Spirits eBusiness Specialists 
(413) 584-0400 
 Download vCard

More information about the interchange-users mailing list