[ic] Recently running cats on 2 IC installs failing

IC Support ic_support at mnwebdesign.com
Fri Aug 26 20:26:27 UTC 2011


> -----Original Message-----
> From: interchange-users-bounces at icdevgroup.org 
> [mailto:interchange-users-bounces at icdevgroup.org] On Behalf 
> Of Mike Heins
> Sent: Thursday, August 25, 2011 6:04 PM
> To: interchange-users at icdevgroup.org
> Subject: Re: [ic] Recently running cats on 2 IC installs failing
> Quoting IC Support (ic_support at mnwebdesign.com):
> > Hi, I have 3 recently running catalogs failing on 2 different 
> > Interchange installations (low traffic settings) on the 
> same server. 
> > One is 4.8.5 and one is 5.6. This seems to have happened after 
> > installing several Centos4 package updates, including a 
> perl update on 
> > my VPS which affected /usr/local/bin/perl. Have I already 
> answered my 
> > own question or can anyone offer a place to start?
> > 
> > Apache 2.2.19	PHP 5.2.17
> > MySQL 5.5.14	Perl 5.14.1
> > 
> > 
> > The 5.6 catalog is running old signals and appears to start fine, 
> > without errors in interchange.cfg, but sends browser a 500 
> Internal Server Error.
> > Nothing of interest in debug.log. Catalog.cfg has this:
> > 
> > c8bQIn9C: - 
> [25/August/2011:16:32:07 -0500] 
> > 1982
> > /cgi-bin/1982 Runtime error: Can't locate object method "func" via 
> > package "DBI::db" at 
> > /usr/local/lib/perl5/site_perl/5.14.1/i686-linux/DBD/mysql.pm
> > line 227.
> I can't help with that, but the other is a signal error. I 
> would, in order of preference for going back to where you 
> were, 1) downgrade Perl back to 5.10 or less, or 2) don't set 
> PERL_SIGNALS unsafe.
> --
> Mike Heins

OK, thanks for that quick reply Mike. I've since installed perl 5.10.1
locally and installed Bundle::Interchange like this:
/usr/local/bin/perl -MCPAN -e 'install "Bundle::Interchange"'

I can now browse the 4.8.5 cats, although I'm getting this error on startup:

Prototype mismatch: sub Vend::Interpolate::S_ISUID: none vs () at
/home/cambridge/chs/interchange/bin/interchange line 2759
Prototype mismatch: sub Vend::Interpolate::S_ISVTX: none vs () at
/home/cambridge/chs/interchange/bin/interchange line 2759
Prototype mismatch: sub Vend::Interpolate::S_ISGID: none vs () at
/home/cambridge/chs/interchange/bin/interchange line 2759

I have checked the 4.8.5 cats over and everything seems to work fine. Any
thoughts on those errors?

My 5.6 Interchange install SEEMS to start without warning or delay, however,
I'm getting this in the cat error.log: oL9xQTPQ: - [26/August/2011:09:08:49 -0500] 1982
/cgi-bin/1982 Runtime error: Can't locate object method "func" via package
"DBI::db" at /usr/local/lib/perl5/site_perl/5.14.1/i686-linux/DBD/mysql.pm
line 227.

I then installed the KitchenSink like this:

/usr/local/bin/perl -MCPAN -e 'install "Bundle::InterchangeKitchenSink"'

Still no joy. Should I be installing these modules with the local perl like:

/usr/local/bin/perl -MCPAN -e etc

Or just

perl -MCPAN -e etc

I have performed all these actions as root except for starting Interchange.

Would a fresh install of Interchange possibly help? I don't think so, as
those cats did not change at all, permissions or otherwise, as DB thankfully
mentioned. I also checked the apache error log. This started after I updated
a lot of server modules, etc., like Apache 1.x to 2.2, MySQL 5.1? To 5.5,
Perl from 5.8.x to 5.14.1, etc

OK, so I keep going....

Using info found here:

I installed un-threaded perl 5.8.3 in /usr/local/bin:

sh Configure

Then I edited config.sh and added this to the end of the config file:


Then ran:

make test
make install
/usr/local/bin/perl -MCPAN -e 'install "Bundle::Interchange"' 

that failed the Bundle install, LWP issues, so I tried this:
perl -MCPAN -e 'install "Bundle::Interchange"'

and that has everything up to date.

But, now my 5.6 cat complains:
must have either MySQL or Postgres
In line 87 of the configuration file 'catalog.cfg':

And my 4.8.5 cats are (currently) running but they won't restart:
Configuring catalog cat1...cat1 config error: Could not tie to
'/home/cambridge/chs/catalogs/cat1/products/variable.gdbm': Invalid argument
at /home/cambridge/chs/interchange/lib/Vend/Table/GDBM.pm line 115, <CONFIG>
line 9.

I do have GDBM installed for perl and /usr/local/bin/perl:
/usr/local/bin/perl -e 'require GDBM_File and print "I have GDBM.\n"'
I have GDBM

I have also found and tried this:
Adding	$ENV{PERL_SIGNALS} = "unsafe";
into the top of bin/interchange, just after the #!/usr/local/bin/perl

I am so lost....any other ideas out there?


More information about the interchange-users mailing list