[ic] Recently running cats on 2 IC installs failing

Peter peter at pajamian.dhs.org
Sat Aug 27 23:08:16 UTC 2011

On 28/08/11 03:06, IC Support wrote:
> Thanks for the reply, Paul. I tried those settings but to no avail. I'm sure
> this is not Interchange as several installation and multiple cats are
> affected. I had just hoped ssomeone would be able to tell by the errors what
> part of my server was causing this (missing module, etc.). The host of my
> VPS is looking at this now.
> Here is another Interchange startup error from another cat:
> Configuring catalog fts...table 'ups_cache' failed: table ups_cache connect
> failed -- install_driver(mysql) failed: Can't load
> '/usr/local/lib/perl5/site_perl/5.10.0/i686-linux/auto/DBD/mysql/mysql.so'
> for module DBD::mysql: libmysqlclient.so.18: cannot open shared object file:
> No such file or directory at
> /usr/local/lib/perl5/5.10.0/i686-linux/DynaLoader.pm line 203.
>  at (eval 354) line 3
> Compilation failed in require at (eval 354) line 3.
> Perhaps a required shared library or dll isn't installed where expected
>  at /home/funtime/fts/ic563/lib/Vend/Table/DBI.pm line 613
> I have mysql installed and DBD::mysql, and I installed the kitchensink, so
> this is strange. I also tried to install the latest 5.6.3 but it fails.
> Running makecat under existing installs also won't start the new cat.
> Thanks to you all for your help!

Hi Curt,

Check if you have selinux enabled and if so disable it.


More information about the interchange-users mailing list