[ic] Virtual Goods download error

Stefan Hornburg (Racke) racke at linuxia.de
Tue Jan 25 19:33:10 UTC 2011

On 01/24/2011 08:06 PM, DB wrote:
> I'm again trying to troubleshoot this issue. I had an older thread but
> thought I'd start a new one with the updated information.
> I've been selling a PDF through my IC 5.6.3 (modified foundation)
> website for years. Recently however, if a customer purchases this PDF
> without being logged in, the sale goes through ok... but when they click
> the download link from the receipt page, the following error is shown:
> Sorry, there was an error in processing this form action. Please report
> the error or try again later. (Can't locate object method "new" via
> package "Vend::UserDB" (perhaps you forgot to load "Vend::UserDB"?) at
> /usr/local/interchange/lib/Vend/UserDB.pm line 2008. )
> I see nothing in the store or main IC error logs at the time the error
> occurred.
> If I go back and log in under the auto-created acocunt, I can then
> download the PDF from the link in the customer's order history.
> If a customer purchases the PDF after first logging in, then the
> download from the receipt page works fine.
> Here's how the files and directories are set up:
> drwxr-xr-x  7 interch interch    4096 Jul  1  2006 download
> drwxrwxr-x  2 interch interch 4096 Dec 24  2003 subdirectory
> -rwxrwxr-x 1 interch interch 2606037 Jan  7  2003 file.pdf
> I've tried this using Apache and lighttpd - same error. Can anyone
> suggest what I might check nest?

First of all I would check for problems with robot detection
(Robot* directives). Ensure that you use recent settings in RobotNotUA.


LinuXia Systems => http://www.linuxia.de/
Expert Interchange Consulting and System Administration
ICDEVGROUP => http://www.icdevgroup.org/
Interchange Development Team

More information about the interchange-users mailing list