[ic] Installing packages (problem with perl-Crypt-SSLeay-0.27-1.i386.rpm on RH 7.0)

Mike Heins [email protected]
Thu Aug 16 12:05:00 2001


Quoting Jason Timm ([email protected]):
> 
> >>While trying to install perl-Crypt-SSLeay-0.27-1.i386.rpm onto RH7.0, I
> get:
> >>
> >>error: failed dependencies:
> >>         libcrypto.so.1   is needed by perl-Crypt-SSLeay-0.27-1
> >>         libssl.so.1   is needed by perl-Crypt-SSLeay-0.27-1
> >
> >Those RPM's were built for openssl-0.9.6, RH 7.0 comes with 0.9.5.  You can
> >probably install both versions and still be able to use the old stuff for
> >binary compatibilty (like RH 7.0 Apache-SSL) and the new stuff for
> >everything else (using symlinks in /lib/..., if you know how).
> 
> Thanks, Dan. At least you got me looking in the right place...  But, I still
> can't get it to work.
> 
> When I tried to install openssl-0.9.6, it reported that it can't because it
> conflicts with openssl-0.9.5a.  I had thought of removing 5a, but there are
> a ton of dependencies to it and I don't want to remove everything else (as
> well as probably more dependencies as well).
> 

You might also try installing Net::SSLeay instead -- I am not sure if it
has the same dependencies, but if you install either it or Crypt::SSLeay
with CPAN, they might work with openssl-0.9.5a.

I assume you are planning on using one of

    Vend::Payment::AuthorizeNet
    Vend::Payment::iTransact
    Vend::Payment::Skipjack

which are the only reasons either module is needed. You only need one
of them...

-- 
Red Hat, Inc., 3005 Nichols Rd., Hamilton, OH  45013
phone +1.513.523.7621      <[email protected]>

"All you need in this life is ignorance and confidence, and
then success is sure." -- Mark Twain