[ic] catalog working, no admin/login, unable to checkout

Peter peter at pajamian.dhs.org
Thu Sep 1 20:25:46 UTC 2011

On 01/09/11 11:59, Curt Hauge wrote:
> $ sudo ./iptables_cfg.sh 
> .	Make sure you can still log in via ssh (but *don't* close your
> current ssh connection until you do!) 
> Well, I can't login with SSH any longer or into my DirectAdmin console on
> port 2222, my email is all down, http is up, and I do have an open SSH
> console. I checked my access via SSH until just before that last command.
> I've googled about but not sure what I'm looking for, can you help me get
> back up? I didn't make any changes to iptables_cfg.sh. I tried to swap out
> iptables.save, re-run sudo ./iptables_cfg.sh, tried stoping then starting as
> root, and then swapped them back when no luck. I'm sure I was the correct
> user/root for these tasks as well.

You're ssh is on a non-standard port (why are you using port 2222 for
ssh?) which is being blocked by the firewall.  You need to first
shutdown iptables:

$ sudo service iptables stop

...at this stage you should be able to connect again (check).

Now edit your iptables_cfg.sh file and copy the entry for ssh but change
the port to 2222, you should also add in lines for the other services
you need, such as email (there is a commented example for smtp, you may
also want to add a line for submission port 587).

when you're done editing iptables_cfg.sh rerun it and you should be good
to go:

$ sudo ./iptables_cfg.sh

Again, make sure you can log in via ssh before dropping your connection.


More information about the interchange-users mailing list