[ic] catalog working, no admin/login, unable to checkout

IC Support ic_support at mnwebdesign.com
Thu Sep 1 21:29:23 UTC 2011


> -----Original Message-----
> From: interchange-users-bounces at icdevgroup.org 
> [mailto:interchange-users-bounces at icdevgroup.org] On Behalf Of Peter
> Sent: Thursday, September 01, 2011 3:26 PM
> To: interchange-users at icdevgroup.org
> Cc: Curt Hauge
> Subject: Re: [ic] catalog working, no admin/login, unable to checkout
> On 01/09/11 11:59, Curt Hauge wrote:
> > $ sudo ./iptables_cfg.sh 
> > .	Make sure you can still log in via ssh (but *don't* close your
> > current ssh connection until you do!)
> >  
> > Well, I can't login with SSH any longer or into my 
> DirectAdmin console 
> > on port 2222, my email is all down, http is up, and I do 
> have an open 
> > SSH console. I checked my access via SSH until just before 
> that last command.
> > I've googled about but not sure what I'm looking for, can 
> you help me 
> > get back up? I didn't make any changes to iptables_cfg.sh. 
> I tried to 
> > swap out iptables.save, re-run sudo ./iptables_cfg.sh, 
> tried stoping 
> > then starting as root, and then swapped them back when no luck. I'm 
> > sure I was the correct user/root for these tasks as well.
> You're ssh is on a non-standard port (why are you using port 2222 for
> ssh?) which is being blocked by the firewall.  You need to 
> first shutdown iptables:
> $ sudo service iptables stop
> ...at this stage you should be able to connect again (check).
> Now edit your iptables_cfg.sh file and copy the entry for ssh 
> but change the port to 2222, you should also add in lines for 
> the other services you need, such as email (there is a 
> commented example for smtp, you may also want to add a line 
> for submission port 587).
> when you're done editing iptables_cfg.sh rerun it and you 
> should be good to go:
> $ sudo ./iptables_cfg.sh
> Again, make sure you can log in via ssh before dropping your 
> connection.
> Peter

OK, I figured everything out, I forgot my host set my VPS SSH on port 1022
while DirectAdmin is on 2222. I am now into installing local perl and failed
1 test. I can't quite figure out where to go from here:

Failed 1 test out of 1695, 99.94% okay.
### Since not all tests were successful, you may want to run some of
### them individually and examine any diagnostic messages they produce.
### See the INSTALL document's section on "make test".
### You have a good chance to get more information by running
###   ./perl harness
### in the 't' directory since most (>=80%) of the tests succeeded.

### You may have to set your dynamic library search path,

### LD_LIBRARY_PATH, to point to the build directory:

###   setenv LD_LIBRARY_PATH `pwd`; cd t; ./perl harness

###   LD_LIBRARY_PATH=`pwd`; export LD_LIBRARY_PATH; cd t; ./perl harness

###   export LD_LIBRARY_PATH=`pwd`; cd t; ./perl harness

### for csh-style shells, like tcsh; or for traditional/modern
### Bourne-style shells, like bash, ksh, and zsh, respectively.
u=4.62  s=2.09  cu=371.72  cs=74.00  scripts=1695  tests=349509
make: *** [test] Error 1

I went here ../cpan/Cwd/t and did:
perl ./cwd.t 

and got this:
opendir(linktest/../../../../../../../../../..): Permission denied at
./cwd.t line 213
not ok 25
#   Failed test at ./cwd.t line 213.
#                   ''
#     doesn't match
ok 26 - abs_path() can be invoked on a file
ok 27 - fast_abs_path() can be invoked on a file
ok 28 - _perl_abs_path() can be invoked on a file
ok 29 - abs_path() can be invoked on a file
ok 30 - fast_abs_path() can be invoked on a file
ok 31 - _perl_abs_path() can be invoked on a file
ok 32 - abs_path() works on files in the root directory
ok 33 - fast_abs_path() works on files in the root directory
ok 34 - _perl_abs_path() works on files in the root directory

and looked up line 213:
like(Cwd::_perl_abs_path($file), qr|$want$|i) if $EXTRA_ABSPATH_TESTS;

looks like it wants a path, I don't have a linktest path...

My google isn't finding me anything with meat ;-)

Any other thoughts on this?

Many thanks!


More information about the interchange-users mailing list