[ic] catalog working, no admin/login, unable to checkout

IC Support ic_support at mnwebdesign.com
Fri Sep 2 14:59:27 UTC 2011


> -----Original Message-----
> From: interchange-users-bounces at icdevgroup.org 
> [mailto:interchange-users-bounces at icdevgroup.org] On Behalf Of Peter
> Sent: Friday, September 02, 2011 1:57 AM
> To: interchange-users at icdevgroup.org
> Subject: Re: [ic] catalog working, no admin/login, unable to checkout
> On 02/09/11 13:08, IC Support wrote:
> > OK, I did this as user curt, from your guide:
> > 
> > $ sudo yum -y install gcc gdbm-devel openssl-devel tk-devel 
> gd-devel 
> > expat-devel make $ cd $ wget 
> > http://www.cpan.org/src/perl-5.12.3.tar.gz
> > $ tar -xvzf perl-5.12.1.tar.gz
> > $ cd perl-5.12.1
> > $ ./Configure -des -Dprefix=/usr/local/perl-5.12.3 $ make $ 
> make test
> > 
> > That is as far as I got, failed 1 test. Should I be root instead?
> Ok, no, this is correct (except I said to do it with 5.12.4 
> but it should have worked with 5.12.3 as well and I have in 
> fact tested that in the past).  I honestly don't know why it 
> failed the test for you but I'll do some further testing and 
> get back to you.  Maybe you have some package installed that 
> is enabling a feature that i don't have and that is what's failing.
> Can you tell me again which test is failing?

as user curt, during 'make test' it fails and gives:

Failed 1 test out of 1695, 99.94% okay.
### Since not all tests were successful, you may want to run some of 
### them individually and examine any diagnostic messages they produce.
### See the INSTALL document's section on "make test".
### You have a good chance to get more information by running
###   ./perl harness
### in the 't' directory since most (>=80%) of the tests succeeded.
### You may have to set your dynamic library search path,
### LD_LIBRARY_PATH, to point to the build directory:
###   setenv LD_LIBRARY_PATH `pwd`; cd t; ./perl harness
###   LD_LIBRARY_PATH=`pwd`; export LD_LIBRARY_PATH; cd t; ./perl harness
###   export LD_LIBRARY_PATH=`pwd`; cd t; ./perl harness
### for csh-style shells, like tcsh; or for traditional/modern 
### Bourne-style shells, like bash, ksh, and zsh, respectively. 
u=4.62  s=2.09  cu=371.72  cs=74.00  scripts=1695  tests=349509

make: *** [test] Error 1

I ran ./perl harness and several tests were skipped for various reasons, but
it was hard to keep track of everything, I may need to run it again (as user
curt) and look for a log file.

I tried:
setenv LD_LIBRARY_PATH `pwd`
but got:
setenv: command not found

I checked around for a way to 'install' setenv and came up empty.

I also went here perl-5.12.4/cpan/Cwd/t and did:
perl ./cwd.t 

and got this:

opendir(linktest/../../../../../../../../../..): Permission denied at
./cwd.t line 213 not ok 25
#   Failed test at ./cwd.t line 213.
#                   ''
#     doesn't match
ok 26 - abs_path() can be invoked on a file 
ok 27 - fast_abs_path() can be invoked on a file 
ok 28 - _perl_abs_path() can be invoked on a file 
ok 29 - abs_path() can be invoked on a file 
ok 30 - fast_abs_path() can be invoked on a file 
ok 31 - _perl_abs_path() can be invoked on a file 
ok 32 - abs_path() works on files in the root directory 
ok 33 - fast_abs_path() works on files in the root directory 
ok 34 - _perl_abs_path() works on files in the root directory

and looked up line 213:
like(Cwd::_perl_abs_path($file), qr|$want$|i) if $EXTRA_ABSPATH_TESTS;

I hope that answers your question.

And this is what has heppened since my last email. I tried configuring and
running make and make test as root. You are saying that I WAS doing it
correctly (running make test as curt), so this may all be moot.

# cd perl-5.12.4
# ./Configure -des -Dprefix=/usr/local/perl-5.12.4 
# make 
# make test 
# make install 
# cd /usr/local 
# sudo ln -s perl-5.12.4 perl 

This got me through make test and the install error free. I got through
Text-Query issues and finished the perl install, however, when I do:

/usr/bin/perl -v
This is perl, v5.8.8 built for x86_64-linux-thread-multi

This perl was built by DirectAdmin when they setup my new VPS

however, /usr/local/bin/perl
This is perl, v5.10.0 built for x86_64-linux-v

This is a version I tried as root (which you once questioned my choice of
version), it won't go away, how can I get it out of there? Do I just remove
/usr/local/bin/perl? Again, maybe I should not be doing this as root.

whereis perl
perl: /usr/src/perl-5.12.4/perl.c /usr/src/perl-5.12.4/perl.h
/usr/src/perl-5.12.4/perl.o /usr/src/perl-5.12.4/perl /usr/bin/perl
/usr/local/bin/perl /usr/local/perl /usr/share/man/man1/perl.1.gz

OK, I am going to take a break for awhile and come back to this later today.
If  you have anything to add please do. 8-)

Many thanks for all your efforts, Peter!


More information about the interchange-users mailing list