[ic] catalog working, no admin/login, unable to checkout

IC Support ic_support at mnwebdesign.com
Thu Sep 15 17:08:59 UTC 2011

Peter said: 

> -----Original Message-----
> From: interchange-users-bounces at icdevgroup.org 
> [mailto:interchange-users-bounces at icdevgroup.org] On Behalf Of Peter
> Sent: Sunday, September 11, 2011 6:55 PM
> To: interchange-users at icdevgroup.org
> Subject: Re: [ic] catalog working, no admin/login, unable to checkout
> On 12/09/11 11:13, IC Support wrote:
> > OK, so I now have a test cat FULLY working and MY cat is running in 
> > admin area. I had to remove the .gdbm and .sql files from products 
> > folder. I was able to get into the user frontend after doing this, 
> > place an order, log in, complete the order, view the receipt, then 
> > when going to home page or any other page it resulted in "Internal 
> > server error". My cat error log has this (and always seemed 
> to have this error):
> > 
> > cnXuas58: - [11/September/2011:17:47:02 
> > -0400]
> > fts1 /cgi-bin/fts1/index.html Runtime error: Can't locate object 
> > method "func" via package "DBI::db" at 
> > 
> /usr/local/perl-5.12.4/lib/site_perl/5.12.4/x86_64-linux/DBD/mysql.pm 
> > line 227.
> You're trying to access a table from a Safe compartment 
> without properly opening the table first.  Figure out which 
> table it is and then open it properly first.  One of the 
> easiest ways to do this is to add something like this to catalog.cfg:
> AutoLoad <<EOA
> [perl tablename][/perl]

I tried Peters suggestion on all tables, one at a time, restarted
Interchange (always starts quickly), and I get the same result. Nothing has
changed in the catalog, so this must be something on my server causing this.
How strange that I can now get to admin area with complete unfettered
access, but not the customer side.

Can anyone tell me, is it safe to remove all .gdbm, .pag, .dir, .sdbm files
from CATROOT/products?
Is there some place I could start to use debugging on this cat to help
figure this out?

I have another IC 5.6.3 install on another domain and that cat was also
running fine on my old server, and now is having issues on every table while
starting Interchange, like this:

table 'area' failed: connect to dbi:mysql:cambridge_1982 failed (create) --
Access denied for user 'admin'@'localhost' (using password: NO)

and I see this 'occasionally' in the cat error.log
- - - [10/September/2011:20:03:33 -0400] 1982 - table 'photos' failed: table
photos connect failed -- DBI connect('cambridge_1982','',...) failed: Access
denied for user 'admin'@'localhost' (using password: NO) at
/home/cambridge/chs/interchange/lib/Vend/Table/DBI.pm line 613

so I look at DBI.pm and find this:

 611 ::logDebug("bad=$bad connecting to $call[0]");
 612                 eval {
 613                         $db = DBI->connect( @call ) unless $bad;
 614                         $db->trace($Global::DataTrace,
 615                                 if $Global::DataTrace and
 616                 };

Then I uncomment the debug in  DBI.pm and uncomment the DEBUG in
interchange.cfg, restart, nothing in debug but I find this when starting

Vend::Table::DBI:debug: bad= connecting to dbi:mysql:cambridge_1982
Vend::Table::DBI:debug: bad=1 connecting to dbi:mysql:cambridge_1982

I have the mysql db installed and accessible from phpMyAdmin, user and pass
is in CATROOT/dbconf/mysql/mysql.cfg:
Variable  SQLUSER  myusername
Variable  SQLPASS  mypassword

Does anyone know how this could be coming up with admin at localhost? This
'DBI' seems to keep coming up, do I need to remove and reinstall that (I
have done a reinstall)?

Is it possible that tarring up these cats, then ftp'ing the .tar files to my
local Windows machine, then ftp'ing up to new server is causing some
problems? I just did a tar -cf archive.tar foo to create the archive.

I will be digging into these problems again today. Any other thoughts or
suggestions are appreciated!


More information about the interchange-users mailing list